GIS pro Biologické aplikace – cvičení

Každé cvičení je děleno do bodů, které člení text na jednotlivé úkoly. Postupem času ubývá vysvětlivek a úkoly spoléhají, že již postupy znáte. Pokud nějaké cvičení vynecháte, zkuste si alespoň přečíst návod.

Kurzívou jsou odlišeny názvy příkazů, „>“ značí další krok nebo podmenu. Kurzívou jsou i tipy.
Podtrženě jsou otázky/úkoly, na které byste měli nalézt odpověď. Následuje postup jak se dobrat k řešení. 

V úkolech mohou být i chytáky pro zamyšlení.

Úvod do ArcCatalog
Otevřete ArcCatalog (Start > Všechny aplikace > ArcGIS > ArcCatalog) 

1. Obsah okna
- vlevo Catalog tree – organizace dat – funguje podobně jako v Průzkumníku souborů ve Windows, s tím rozdílem, že zobrazuje pouze uživatelem připojené složky a soubory v určitých formátech. Proto mohou být některé složky prázdné.
- vpravo tabs (Contents, Preview, Description (dříve Metadata - stále se mnohde objevuje i tento správnější název) – umožňují zkoumat obsah vybraných složek a souborů

2. Tvorba adresářů, souborů
Na začátku jakékoli práce v GIS je dobré si pořádně rozmyslet organizaci dat. Přesouvání dat uprostřed rozdělané práce může způsobit potíže (časem uvidíte jaké). Struktura a tvorba adresářů a souborů v ArcCatalog je obdobná jako např. v Průzkumníku souborů ve Windows.

Ve svém adresáři vytvořte podadresář Uvod_ArcGIS (pro tentokrát ještě v průzkumníku). Naučte se nepoužívat v názvech adresářů ani souborů mezery, pomlčky, a často i české znaky, pro některé operace je to nepřekonatelná překážka! Do Uvodu si nakopírujte data pro toto cvičení z adresáře cv1 (ten získáte rozzipováním zaheslovaného souboru z webu). Ujistěte se, že v místě, kde jste vytvořili složku Uvod_ArcGIS máte po zkopírování dostatek místa. Mnoho ArcGIS problémů pramení z nedostatku místa na disku, jelikož ArcGIS si do této složky ukládá mezivýstupy. Sám ArcGIS to však nikdy nepřizná.
3. Folder connection
Abyste nemuseli pokaždé při hledání dat procházet celý katalog, vytvoříte si přímé spojení k vaší složce: 
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File> Connect to folder nebo [image: image29.bmp],

Poté, co najdete vaši složku Uvod_ArcGIS a odklepnete OK, se v Catalog tree objeví nová položka, která popisuje cestu k vašim datům.

Spojení se odstraní pomocí File > Disconnect from folder (nebo příslušná ikonka – hned vedle). Odstraní se pouze spojení, nikoli data samotná!
Pomocí příkazu ve File > New > Shapefile se vytvoří nový soubor typu shapefile, toho si užijete později při tvorbě vašich vlastních vrstev. Dá se tu vytvořit i nový soubor typu Geodatabase atd. 
Co je geodatabase? Nápověda vám to vysvětlí. Stejné příkazy jsou pak i v kontextové nabídce. 

Dokud nebyla připojena žádná složka, tak toto menu zobrazovalo jen možnost Connect to folder.

4. Zkoumání obsahu složek
Contents: zajímá vás, co všechno za soubory se ve složce nachází. Stejně jako v Průzkumníku si můžete zvolit, jaké informace se zobrazí. Jsou 4 možnosti, vyberte Details. 
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Všimněte si, že každý datový typ má jinou ikonku (což usnadňuje orientaci v datech).
Preview: chcete si v ArcMap otevřít mapu, ale nevíte, zda zahrnuje přesně to území, které potřebujete. Než ji tedy otevřete v ArcMap (což zejména v případě načítání rastrů nemusí být úplně rychlé), prohlédnete si mapu zde v Preview. 

V Catalog tree vyberte soubor fytog_okr z adresáře Uvod_ArcGIS a klikněte na Preview
Stejně jako v ArcMap můžete i v tomto náhledu můžete použít zoom in [image: image3.png]


, zoom out [image: image4.png]


, pan [image: image5.png]


, full extent [image: image6.png]


 a identify[image: image7.png]


. Zoom in funguje tak, že kliknete na ikonku a pak na místo, které chcete přiblížit, druhá možnost je kliknout do mapy a pak tažením kurzoru vytvořit výřez, který se zvětší. Totéž platí pro zoom out. Pan umožňuje posun mapy (kliknout na ikonku, pak v mapě kliknout a táhnout). Full extent vrací původní rozsah (pohled na celý obsah souboru). Kliknutím na identify a pak na polygon se zobrazí vlastnosti daného polygonu. Vyzkoušejte si to.

Preview umožňuje zkoumat i obsah atributových tabulek. Ve spodní části okna zvolíte místo Geography Table a zobrazí se atributová tabulka. V řádcích jsou záznamy jednotlivých polygonů, ve sloupcích jejich vlastnosti (atributy). S tabulkou a jejím vzhledem je zde možné provádět všelijaké kejkle, jako např. seřadit záznamy, počítat statistiky a podobně, ale tyto operace si vyzkoušíte až v ArcMap, kde se to dělá stejným způsobem.

Jakou rozlohu má fytogeografický okres Brdy? 
Description:  by měla obsahovat bližší informace o datech, např. za jakým účelem vznikla, jak často jsou aktualizována, co znamenají jednotlivé kódy v atributové tabulce atd. Prohlédněte si metadata k vrstvě fytog_okr a potenc1.
V jakém souřadnicovém systému jsou tyto vrstvy zobrazeny? 
Co znamenají hodnoty v kolonce POTENC v atributové tabulce vrstvy potenc1? 
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Vytvořit description je velmi jednoduché. Slouží k tomu následující příkazy: 
Print, Edit, Import přímo na záložce Description.
Klikněte na Edit Zobrazí se vám formulář, který hravě vyplníte. Vyzkoušíte si to později při tvorbě vlastních vrstev. Description/Metadata jsou nepostradatelná pro budoucí práci, když už zapomenete vše, co jste o daném souboru věděli, když jste ho vytvářeli. Nezbytná jsou i při výměně či šíření dat.
Styl metadat můžete měnit v Customize > ArcCatalog Options > Metadata. Je zde i styl podle směrnice INSPIRE. Jakmile styl změníte, je třeba přejít na jinou položku.
5. Přidávání dat do ArcMap
Z ArcCatalog je také možné přidávat vrstvy do ArcMap. V ArcMap to sice jde i jinak, ale tato možnost se hodí například, chcete-li přidat zároveň několik souborů z různých adresářů. 

Otevřete si ArcMap pomocí ikonky [image: image8.png]


. 

Klikněte na Cancel v okně výběru dokumentu. Zmenšete si okno ArcMap tak, abyste viděli vedle něj i ArcCatalog (stačí část s Catalog tree). Kliknutím a přetažením do ArcMap se přidá vybraná vrstva. Podobně lze přetahovat i z Windows, pro shapefile je však vybrat pouze soubor s příponou .shp, bez pomocných souborů.
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S příchodem ArcGIS 10 je ArcCatalog též integrován přímo v ArcMap [image: image9.png]


. Po spuštění se usídlí v pravé části obrazovky a dle nastavení se schovává, tak abyste mohli využívat i jiné nástroje ve stejné obslati a nic vám nepřekáželo.

V liště s názvem je křížek na zavření katalogu a špendlík, který umožňuje připnout okno Catalogu tak, aby se neskrývalo. Stejně se chovají i další panely (Toolbox, Search, Results,...) a též obsah (Table of contents) na levé straně, který se defaultně neschovává.

V tomto Catalogu lze provádět všechny důležité úkony jako v samostatném Catalogu, včetně přetahování souborů do mapy. Pomocí tlačítka [image: image10.png]


 můžete měnit styl zobrazení souborů v catalogu včetně užitečného podokna. Navíc přibyla tlačítka pro domovskou složku a geodatabázi [image: image11.png]


. Domovská složka je vždy ta, kde se nachází aktuálně načtená mapa (soubor. mxd), pokud jde o neuloženou, pak jde o složku  \Documents\ArcGIS\ aktuálního uživatele. Tam se vytváží i Default.gdb – výchozí geodatabáze, tu můžete změnit pomocí pravého tlačítka myši na své geodatabázi. Pokud nemůžete najít své výsledky, zkuste se podvat sem.
Složky připojené v samosttaném ArcCatalogu jsou zde též.

Bohužel zde chybí rychlý náhled. Description lze nalézt pod pravým tlačítkem – Item description, následně se zorbrazí nové okno i s možností náhledu.

Úvod do ArcMap

1. Přidávání a odstraňování vrstev
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Pokud jste přidali v předchozím kroku nějakou vrstvu, klikněte na její název v Table of contents pravým tlačítkem myši a zvolte Remove. Pak pomocí [image: image12.png]


 přidejte z adresáře Uvod_ArcGIS všechny vrstvy s příponou SHP (shapefile). Více vrstev zároveň můžete vybrat pomocí Ctrl. Upozornění The following data sources you added are missing spatial reference information. This data can be drawn in ArcMap, but cannot be projected si prozatím nevšímejte a odsouhlaste ho. Zabývat se jím budete v kapitole o projekci dat. Všimněte si i trojúhelníčku i ikonky [image: image13.png]


, zde lze zvolit i jiné typy dat –Basemap, kde lze nalézt podkladové mapy (nikoliv data) pro libovolnou lokalitu – Letecké a satelitní snímky, topografickou mapu, přehlednou pokladovou mapu, mapu ve stylu National Geographic, OpenStreetMap a další zajímavé zdroje. Zásadní zdroj se ale skrývá pod Add Data from ArcGIS Online kde je nepřeberné množství dat z celého světa. S některými z nich se dá i dále pracovat (nejen jen jako podklad). 
V pravé části okna se postupně objeví mapa ČR složená z několika vrstev. Přehled přidaných vrstev vidíte v levé části okna v Table of contents (dá se zavřít a zase přidat z Windows, nebo odepnout aby se schovávala k pravému okraji). Každá vrstva nese název a pod ním se nachází symbol, ze kterého je zřejmé, zda se jedná o vrstvu prvků bodových, liniových anebo polygonů. Vlevo od názvu vrstvy se nachází čtvercové políčko. Pokud je zaškrtnuto, znamená to, že je vrstva zobrazena. Pokud do čtverečku kliknete, zaškrtnutí zmizí a vrstva v mapě zobrazena nebude. Kliknete-li do čtverečku znovu, bude vrstva opět zaškrtnuta a zobrazena. 

Pokud vidíte obrysů ČR více, nazoomujte k tomu, kde je víc dat, nebo klikněte pravým tlačítkem na vrstvu VOD_TOK a zvolte Zoom to layer.
2. Symboly a barvy
ArcMap nezná smysl zobrazovaných prvků a přiřazuje jim tudíž symboly a barvy celkem náhodně. Vy si teď symboly a barvy změníte tak, aby byla mapa na první pohled čitelná. Klikněte dvakrát na symbol, který se nachází pod názvem vrstvy hrcr_lin. V nabídce najděte symbol pro Boundary, State a případně zvolte požadovanou barvu a velikost. Stejný postup použijte i pro další symboly. Vodní toky nechť jsou světle modré, silnice červené a vodní plochy tmavě modré. Lze využít i okénko vyhledávání v symbolech (samozřejmě anglicky).
Vrstvy fytogeografické okresy a potenciální vegetace obsahují několik kategorií, které byste rádi zobrazili různými barvami. Kliknětě pravým tlačítkem myši na název vrstvy, zcela dole pak na Properties a nakonec na záložku Symbology. V Categories zvolte Unique values, ve Value field FYT_OBL a Add all values. Dále byste mohli měnit barvy a popisky, ale to teď nechte být. OK. Obdobně pro potenciální vegetaci, tam zadejte ve Value field HODNOTA.
Tip: Properties se zobrazí i při pokliku na název vrstvy, barvy jednotlivých kategorií lze měnit podobně, jako jste měnili hranici – poklikem na symbol. Ctrl+dvouklik na název otevře Atributovou tabulku (viz dále)
3. Pořadí vrstev

Klikněte na tlačítko [image: image14.png]


a kliknutím do mapy a tažením vytvořte výřez zhruba v místech, kde se nachází Lipenská přehrada. Je tam nějaká vodní plocha? Pokud ne, je to tím, že se vrstva VOD_PL nachází pod vrstvou fytog_okr a potenc1, které ji zcela překrývají.

Jak je to tedy s pořadím zobrazených vrstev? Vrstva, která je v Table of contents uvedena na prvním místě, se v mapě zobrazí navrchu (byla navrch přidána jako poslední) a ta na posledním místě je zobrazena úplně vespod (byla přidána jako první). Bodové s liniové vrstvy jsou vždy „průhledné“, polygonové jsou průhledné okolo a uvnitř defaultně vybarvené.
Klikněte znovu na Add data a všimněte si, v jakém pořadí jsou vrstvy uloženy, pak se podívejte do Table of contents. Zjistíte, že pořadí je jiné. ArcMap se stará o to, aby bodové prvky nebyly překryty například prvky polygonovými, a proto vždy jako první přidá polygony, pak až linie a nakonec body. Pořadí vrstev se nicméně dá měnit. Klikněte na název vrstvy VOD_PL a zároveň táhněte myší směrem nahoru pod názvy bodových vrstev. Vrstva vodních ploch by se měla přesunout a zobrazit. Klikněte na full extent[image: image15.png]


, ať vidíte mapu opět v celém rozsahu. 

Pokud chcete vidět fytogeografické okresy i potenciální vegetaci zároveň, můžete například fytogeografické oblasti zobrazit jen obrysově a ne plnou barvou. Klikněte na symbol pro mezofytikum a zvolte Hollow, případně zvolte barvu obrysu. Druhou možností je zprůsvitnit vrchní vrstvu (Properties > Display > Transparent třeba 70 %).

4. Atributová tabulka
Každá vrstva má svou atributovou tabulku: pravým tlačítkem na název vrstvy a Open attribute table. Prohlédněte si atributovou tabulku fytogeografických okresů. Údaje v tabulce je možné setřídit podle kteréhokoli sloupce. Klikněte na záhlaví sloupce Area pravým tlačítkem a Sort ascending. 

Který fytogeografický okres má nejmenší rozlohu? A kde se nachází?

To zjistíte tak, že kliknete na příslušný řádek úplně vlevo, celý se vám označí tyrkysovou barvou. Stejně tak se označí tyrkysovou barvou i v mapě. Pokud ho v mapě nevídíte, zvolte na vrchní liště Selection a Zoom to selected feature. Stejný příkaz lze najít i pod pravým tlačítkem na pravém okraji vybraného řádku nebo použijte ikonu [image: image16.png]


. Kromě Zoom to je v kontextovém menu pravého tlačítka i příkaz Flash, který vám pomůže prvek najít probliknutím a Copy Selected, který zkopíruje vybrané řádky do schránky (např. pro zkopírování do Excelu). 

Teď je zase moc blízko, použijte [image: image17.png]


 nebo [image: image18.png]


. Chcete-li se ujistit, že je to opravdu on, klikněte na [image: image19.png]


 Identify a pak na daný polygon. Zobrazí se vám všechny příslušné údaje z tabulky. Pak z menu Selection vyberte Clear selected features (nebo ikona [image: image20.png]


). Toto je zvlášť důležité, jelikož mnohé nástroje pracují s vybranými prvky.
Kolik polygonů obsahuje vrstva potenc1? 

Otevřete její tabulku a všimněte si [image: image21.png]Recard: 14| (| 1 »[»1|  Show:[ Al Selected | Records (0 outof 25 Selected) aptons




5. Výběr
Teď byste rádi zjistili, kde se nachází fyt. okres Maloskalsko. Mohli byste si v tabulce setřídit okresy podle abecedy, ale teď si vyzkoušíte jiný postup. Selection > Select by attributes. V okně atributové tabulky k tomu složí ikona [image: image22.png]


. V Layer fyt_okr, ve Field dvojklik na FYT_OKR, pak = a po Get unique values dvojklik na Maloskalsko. Mělo by to vypadat následovně:

[image: image23.png]SELECT * FROM fytog_okr WHERE:





Můžete příkaz napsat i z klávesnice, ale pozor na uvozovky a mezery, ty tam musejí být. Opět se vám v mapě polygon zvýrazní modrou tyrkysovou barvou. 

Pomocí SQL (Structured Query Language) můžete zadávat i komplikovanější dotazy, k dispozici máte matematické i logické operace. K tomu více později. Vyhledávat můžete taky příkazem Find and replace v menu [image: image24.png]


 nad tabulkou, zde ale nejde vytvářet výběry.

Teď vyberte z vrstvy vodních ploch všechny polygony rybníků (TYP_VPL = R), vytvoříte z nich novou vrstvu. Poté, co jste vybrali rybníky, pravoklik na název vrstvy (V Table of Contents), pak Data > Export data, Export selected features a uložit jako rybniky do adresáře Uvod_ArcGIS, typ shapefile. Přidat novou vrstvu do mapy OK. V Průzkumníku souborů se pak podívejte, kolik souborů vám přibylo. Nejméně tři (shp ukládá souřadnice, dbf atributová data a shx indexy k propojení obou předchozích), ale pravděpodobně ještě 3 další (prj pro souřadnicový systém…). Chcete-li přesouvat nebo kopírovat vrstvu rybniky, pak musíte vzít všechny příslušné soubory! ArcCatalog vám vždy zobrazí pouze jeden (.shp) a postará se přesun všech potřebných souborů.
6. Ukládání dat
Chcete práci s tímto dokumentem ukončit, ale rádi byste se k němu později vrátili, uložíte si tedy celý mapový dokument se všemi vrstvami (.mxd). V menu File klikněte na Save a uložte dokument pod názvem uvod do adresáře Uvod_ArcGIS. Pak ArcMap zavřete. Průběžné ukládání mxd je základem úspěšné práce s ArcGIS.
V Total Commanderu vyberte všechny soubory s názvem rybniky a přesuňte je do adresáře o úroveň výš. Nestačí je zkopírovat, jde o to, aby zmizely z adresáře Uvod_ArcGIS. Pak otevřete mapový dokument uvod.mxd. Vrstva rybniky se vám nezobrazí. Pravoklik na název vrstvy a Properties > Source. Kde hledá ArcMap vrstvu rybniky? Set data source a najít, kde se rybniky nacházejí teď. 

Mapový dokument neslouží k ukládání dat jako takových, nýbrž k ukládání cesty k datům. ArcMap má přednastavené ukládání celých (absolutních) cest. Příkladem takové cesty je C:\GIS\Uvod_ArcGIS\rybniky.shp
Má-li být vrstva zobrazena, musí se skutečně nacházet na disku C v adresáři GIS a podadresáři Uvod_ArcGIS. Pokud byste mapový dokument chtěli přenést na jiný počítač, pak musíte zajistit, že i na něm budou mít adresáře stejnou strukturu. To je dost nepraktické, proto existuje možnost uložit mapový dokument s relativní cestou. Příkladem takové cesty je: \Uvod_ArcGIS\rybniky.shp  

V tomto případě tedy stačí udržet stejný název přímo nadřízeného adresáře a nezáleží na tom, zda se nachází na disku C nebo F. Příkaz pro ukládání relativní cesty najdete pod:
File > Map Document  properties > zaškrtávátko Store relative path names. 
Toto nastavení se vám bude hodit u všech cvičení, zvlášť, když si je odnesete k jinému počítači. V menu Customize > ArcMap Options > General je zaškrtávátko Make relative paths the default for new map documents.
Všimněte si, že při otevření mapového dokumentu se všechny vrstvy zobrazily přesně tak, jak vypadaly v okamžiku uložení, tj. ve stejném zvětšení, se stejnými symboly a barvami atp. 
Zavřete ArcMap a opět ho otevřete, začnětě s New empty map. Přidejte všechny shp vrstvy z adresáře Uvod_ArcGIS. 
Jaký je rozdíl mezi tím, když otevřete mapový dokument a když do prázdné mapy přidáte ty stejné vrstvy?

Změnte ještě jednou zobrazení fytog_okr a pravoklik na název vrstvy, pak Save as layer file. Ještě jednou klikněte na název vrstvy a zvolte Remove. Pak přidejte vrstvu fytog_okr.shp. Jak se zobrazila? Přidejte vrstvu fytog_okr.lyr. Zase ji odstraňte. 

Symbologie uchovaná v layer file se dá do shapefile importovat. Klikněte pravou myší na název vrstvy fytog_okr.shp a jděte na Properties > Symbology > Import, pak najděte příslušný layer file. Nechte zaškrtnutou možnost Import complete symbology definition, ale všimněte si i ostatních. OK. 

Od verze ArcGIS10 můžete též vytvářet Layer Package .lpk, což je něco na způsob komprimovaného souboru, který obsahuje všechny soubory patřící k shp a navíc lyr. Není kompatibilní se staršími verzemi GIS. Je vhodný pro výměnu dat (netřeba komprimovat nebo posílat jednotlivě). Příkaz k jeho vytvoření - pravoklik na název vrstvy, pak Create Layer Package – zvolte jméno a umístění a dejte Analyze. ArcGIS následně zkontroluje zda je vše OK a pokud ne, vyhodí seznam chyb, každou si pak můžete rozkliknout a opravit. Jakmile bude vše OK, můžete stisknout tlačítko Share. Chybějící souřadnicový systém si vysvětlíme příště, pro tentokrát zkuste nají ta vybrat S-JTSK Krovak East North.
 Tento formát bohužel po přidání do mapy vytváří lokální kopii ve složce uživatele a tudíž není vhodný pro šíření dat spolu s MXD (i kdyby měl relativní cesty). K tomu složí Map package (File > Share > Map package).
7. Datové formáty a typy
Zatím jste pracovali pouze s jedním typem vektorových dat (shapefile). Jiným typem je coverage. Příkladem dat v této podobě je Natura 2000. Prozkoumejte, z čeho se skládá vrstva natura a v nápovědě si najděte další informace o coverage. Všimněte si též jak je uložena na disku.
Jako ukázku rastrových dat máte v adresáři Uvod_ArcGIS vrstvu dem (digital elevation model). Odstraňte teď všechny vrstvy, které jste zobrazili v předchozích krocích a přidejte dem. Pokud se vás ArcMap zeptá, zda má postavit pyramidy, řekněte, že ano a podívejte se do nápovědy, co to znamená. Zkuste si část mapy hodně přiblížit. Pak otevřete atributovou tabulku. Jak jsou data v rastru uložena? 
Ještě jiným formátem a modelem terénu je TIN (Triangular irregular network). Prozkoumejte ho. 
Nově vytvořenou mapovou kompozici si můžete uložit do jiného souboru File > Save as případně Save a Copy kde lze nastavit i formát kompatibilní  se staršími verzemi ArcMap.
8. Tvorba mapového výstupu
Při tvorbě mapového výstupu jsou důležité následující příkazy a možnosti:

Z vrchní lišty 
View > Layout view – v něm se tvoří výsledný výstup
Insert title, legend, north arrow, scale bar (adjust width)
Pravoklik mimo mapu > Page and Print setup 

File > Export map
Vytvořte mapu potenciální vegetace ČR se všemi náležitostmi (název, legenda, severka, měřítko). Zvolte vhodné barvy, aby byla mapa na první pohled čitelná. Můžete například sloučit některé kategorie do jedné (třeba všechny dubové lesy). Postupujte jako v bodě 2. až po Add all values, pak s Ctrl vyberte několik hodnot (např. 1, 2, 3) a pravoklik > Group values. 
 SHAPE  \* MERGEFORMAT 
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